Symptom:
After installing Target for ArcGIS I can no longer access some or all of the Geosoft toolbars. The Geosoft toolbars are either not visible in the list of available toolbars that can be loaded or the menu items in the Geosoft toolbars are greyed out.
This problem can also present itself in the following error:
"ArcGIS Desktop has encountered a serious application error and is unable to continue."
Resolution:
First, close down ArcMap and sign out of Seequent Connector.
Once complete, open ArcMap and see if the Geosoft toolbar appears successfully again.
If this does not resolve the issue, please try the following:
- Close ArcMap if it is open.
- Go to the following folder:
C:\Program Files (x86)\Geosoft\Desktop Applications 9\bin - Right-click on arcgispostbootstrap.exe and click Run as Admininstrator.
The command prompt will flash open and then close immediately.
- Launch ArcMap and check that access to the Geosoft Toolbars has been restored.
If the above steps do not fix the problem try the following:
- Type command prompt into the Windows search bar.
- Right-click on the Command Prompt and click Run as Administrator.
- Change directory to:
C:\Program Files (x86)\Geosoft\Desktop Applications 9\bin - Copy and paste the following command (including the quotations) into the command prompt:
“C:\Program Files (x86)\Common Files\ArcGIS\bin\ESRIRegAsm.exe" geoarcgis.dll /p:Desktop /v:10.0
NOTE: The quotations above have to be typed manually into the command prompt. Copy and pasting the quotations will result in a command prompt error - (change the ArcGIS version at the end of the command to your current installed version. ie. for 10.8.1 use 10.8 in the above command).
- Press Enter.
For Geochemistry for ArcGIS users, there is an additional command to run:
"C:\Program Files (x86)\Common Files\ArcGIS\bin\ESRIRegAsm.exe" Geosoft.ArcGIS.GeochemArcMapExtension.dll /p:Desktop /v:10.0
(remember again to change the ArcGIS version at the end of the command to your current installed version. ie. for 10.8.1 use 10.8 in the above command).
Please contact Support if none of the above solves the problem.
Root Cause:
The installation of Target for ArcGIS is silently failing when attempting to register the extensions and raster dlls. This is resulting in a partial install.
A previous install might have not been uninstalled correctly and have left over some registration files which prevent Target for ArcGIS from registering.