Symptom:
When trying to access Leapfrog, the application appears to freeze with the 'Retrieving Permissions' popup in the bottom right.
Resolution:
There are a few potential resolutions to this issue depending on the root cause.
If no licencing/log in screen appears before the application is getting stuck in the retrieving permissions stage, then it may be that the licencing dialog is opening but is ending up on a screen that is not visible (this can be a common occurrence if there is frequent connecting and disconnecting of external monitors). If this is the case, the resolution is to open Leapfrog and get to the 'Retrieving Permissions' stage and then do the following:
- Bring the Leapfrog application up to the front using Alt-Tab
- Hit this key sequence: Alt-Space-M, followed by the Up,Down,Left, or Right arrow (any arrow works)
- Move the cursor on to the screen.
These steps should lock the cursor to the off-screen licence window and allow it to be dragged into view.
If the PC setup being used consists of external monitors plugged into a laptop, then the following steps can also be used to try and resolve the issue:
- Unplug the external monitors from the laptop
- Open the Leapfrog application and obtain a licence
- Plug the external monitors back into the laptop
If the above steps do not resolve the issue, try the following:
- Close the Leapfrog application
- Navigate to C:\Users<user>\AppData\Local\ARANZ Geo\<product>
- Delete the licence file found there
- Try reopening Leapfrog
This will remove any lingering licences that may be causing problems and force a new sign in.
If the issue is still occurring after trying the above resolution methods please contact support@seequent.com. If you do this, please give us a much detail as possible about where in the licencing process Leapfrog is getting stuck (i.e. which windows/dialogs are you seeing before the application freezes).
Root Cause:
This issue can have several root causes. Most common is the licence dialog appearing on a screen which is not visible to the user which is generally caused by frequent connecting and disconnecting of external monitors.