Symptom:
I have tried to launch the installer for Geosoft Desktop applications and nothing happens. In my task manager I see two instances of the 32-bit installer running but nothing appears to be progressing.
In some cases, Seequent Connector is able to install but the full installation fails.
Resolution:
Before diving into the resolution below, ensure you are not on Windows 8. Seequent Connector and Geosoft Desktop Applications are supported on Windows 8.1 64-bit and Windows 10 64-bit. If you are on Windows 8, you will need to update to Windows 8.1. This Microsoft article outlines how to update from Windows 8 to 8.1.
If you are on a supported operating system, try the following resolutions:
- Ensure there is no firewall or security applications inhibiting Geosoft Desktop Applications from installing.
- Ensure that you have administrative permissions to install.
- Ensure all available Windows updates have been installed.
- Using the Control Panel ensure .NET Framework 4.8 is installed.
- Download and run the following tool https://support.microsoft.com/en-ca/help/17588/windows-fix-problems-that-block-programs-being-installed-or-removed to see if there is a previous Geosoft Desktop Application installed that is hindering the current install
- Try rebooting your system and then run the installation.
- See if you have 'Write' permissions on this folder C:\Users\%USERNAME%\Documents\Geosoft\Desktop Applications 9. If you do not have permissions or are unsure please follow the instructions outlined in https://www.tenforums.com/tutorials/87858-add-protected-folders-controlled-folder-access-windows-10-a.html
Root Cause:
There could be multiple reasons as to why the application will not install. Most of the cases can be solved by doing one or multiple workflows highlighted above.
Please contact support@seequent.com if you have tried these workflows and are still running into installation issues.