Symptom:
I have added Azure layers to my map by going to Data Servers > Add Azure Map Imagery. The Azure image titles are added to the map but they appear to be misaligned, oriented improperly, or in the wrong location.
Resolution:
This is a known limitation with Azure Maps. It has been logged in our system, but our developers have been unable to pinpoint the root cause of the issue. The believe at the moment is that it happens from time to time when internet speed drops or when there is heavy traffic on the service provider you're using.
Despite our best efforts we have been unable to fully address the issue, likely because it is influenced by factors outside our control.
Most customer find it will work if they jump on a stronger connection and try connecting at a different time of day when internet traffic is lower. Some customers have also reported success disconnecting from their home internet, and hot spotting to their cell phone (that use a different provider) to get the images they are after.
As an alternative, you might be able to find the layer your after on Azure or Bing Maps. However, images exported from Azure Maps may not contain projection information, in which case you will need to manually georeference them using this article: https://my.seequent.com/support/knowledgebase/kA330000000V1ftCAC
Root Cause:
Has mostly been reported when on weaker internet speeds or when traffic has spiked on a specific service provider.